Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8155834

FXUIToolkit.showBlockedDialog() - problem when run with older jre

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Duplicate
    • Affects Version/s: 8u20, 9
    • Fix Version/s: None
    • Component/s: deploy

      Description

      calls from JDK9 or later JDK8 deployment code to showBlockedDialog() result in a AbstractMethodException when run with JDK7 or JDK8 before 8u20.
      This method in com.sun.deploy.uitoolkit.ui.UIFactory should be made non-abstract, and some default implementation should be used.

      you can see this installing JDK9 and 7u80 then run:
      http://oklahoma.us.oracle.com/www/tests/dialogs/jnlp/fx7.jnlp
      look at 11: showBlockedDialog()

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                herrick Andy Herrick
                Reporter:
                herrick Andy Herrick
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: