Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8155837

FXUIToolkit.showSandboxSecurityDialog fails when running jre below 7u21

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 8u102, 9
    • Fix Version/s: 9
    • Component/s: deploy
    • Subcomponent:
    • Introduced In Version:
    • Resolved In Build:
      b120

      Backports

        Description

        When running an FX app with signed sandbox jar, with JDK8 or JDK9 deploy code and using JRE less than 7u21 showSandboxSecurityDialog will get AbstractMethodException.
        There is no showSandboxSecurityDuialog method in FXUIToolkit before 7u21.

        Also calls from JDK9 or later JDK8 deployment code to showBlockedDialog() result in a AbstractMethodException when run with FX in JDK7 or JDK8 before 8u20.
        This method in com.sun.deploy.uitoolkit.ui.UIFactory should be made non-abstract, and some default implementation should be used.

        Finally several String resources used by old FXUIToolkit were removed - restoring them.

        All problems can be seen, and fix verified, when installed JDK9 and 7u10 and running:
        http://oklahoma.us.oracle.com/www/tests/dialogs/jnlp/fx7.jnlp

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  herrick Andy Herrick
                  Reporter:
                  herrick Andy Herrick
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: