Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8155992

Change name of StealRegionCompactionTask to something that emphasizes the compaction task.

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
      gc
    • Resolved In Build:
      b120

      Description

      StealRegionCompactionTask implies that the task is for stealing but that is not true since 8150994. The name is now misleading and dangerous because stealings tasks can sometimes get special treatment. Some name such as CompactionTaskWithStealing would do

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jmasa Jon Masamitsu (Inactive)
              Reporter:
              jmasa Jon Masamitsu (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: