Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8156121

"Fail forward" fails for GTK3 if no GTK2 available

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: client-libs
    • Labels:
    • Environment:

      Ubuntu 16.04 without libgtk-x11-2.so

    • Subcomponent:
    • Introduced In Build:
      b118
    • Resolved In Build:
      b124

      Description

      Running the attached test on a specially prepared machine without libgtk-x11-2.so but with GTK-3 available, I observe that JDK doesn't use that available GTK-3 but reports "No GTK LaF supported" instead.

      My version of JDK has the JDK-8145547 fix.

        Attachments

          Activity

            People

            • Assignee:
              ssadetsky Semyon Sadetsky (Inactive)
              Reporter:
              yan Yuri Nesterenko
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: