Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8145568 JEP 283: Enable GTK 3 on Linux
  3. JDK-8156128

Tests for [AWT/Swing] Conditional support for GTK 3 on Linux

    XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: client-libs
    • Labels:
    • Environment:

      Linux

      Description

      According to the plan, create two/three tests for classic client with various scenarios of jdk.gtk.version property.
      Namely, cover scenarios
      -- GTK v2 demanded and used
      -- GTK v3 demanded and used
      -- GTK v3 demaned but not available
      -- GTK v2 demanded but not available

      To force library load, a Swing JFrame may demand GTKLookAnfFeel.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              yan Yuri Nesterenko
              Reporter:
              yan Yuri Nesterenko
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: