Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8157213

HiDPI support for Linux creates unnecessary dependency

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: javafx
    • Labels:
      None

      Description

      The HiDPI support for Linux added calls to g_settings for the org.gnome.desktop.interface schema which may not exist on all desktops. If the schema doesn't exist the gsettings module responds by aborting the process.

      We should be scanning for the presence of this schema before attempting to query it to avoid the extreme exception handling of the gsettings API.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                flar Jim Graham
                Reporter:
                flar Jim Graham
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: