Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8157445

Javawebstart loads jars from MANIFEST

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Duplicate
    • Affects Version/s: 8u92
    • Fix Version/s: None
    • Component/s: deploy
    • Subcomponent:
    • CPU:
      x86
    • OS:
      windows_8

      Description

      FULL PRODUCT VERSION :
      Java Web Start 11.92.2.14
      JRE-Version verwenden 1.8.0_92-b14 Java HotSpot(TM) 64-Bit Server VM

      ADDITIONAL OS VERSION INFORMATION :
      Windows 8.1 Pro

      A DESCRIPTION OF THE PROBLEM :
      The Classloader of Javawebstart loads also jars which are NOT specified in JNLP descriptor.

      E.g. xercesImpl.jar will be loaded because in JNLP xalan-2.7.0.jar
      <jar href="client/xalan-2.7.0.jar" /> because in MANIFEST.MF is the entry
      Class-Path: xercesImpl.jar xml-apis.jar serializer.jar.

      Classpath entries in MANIFEST.MF should be ignored be javaws

      REGRESSION. Last worked in version 8u77


      REPRODUCIBILITY :
      This bug can be reproduced always.

      SUPPORT :
      YES

        Issue Links

          Activity

          pardesha Pardeep Sharma added a comment -
          This looks like a duplicate of JDK-8155076 which is in progress.

            People

            • Assignee:
              Unassigned
              Reporter:
              webbuggrp Webbug Group
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: