Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8157474

clean up/simplify/rename ModuleWrappers class

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 9
    • Component/s: tools
    • Subcomponent:
    • Resolved In Build:
      b120
    • Verification:
      Not verified

      Description

      The ModuleWrappers class could be simplified by reducing the lazy reflective lookup to a single init() method per class.

      In addition, the class should be renamed to JDK9Wrappers, partly to indicate the temporary nature of the class, and partly to allow the possibility of non-module API being supported in the class.

        Attachments

          Activity

            People

            • Assignee:
              jjg Jonathan Gibbons
              Reporter:
              jjg Jonathan Gibbons
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: