Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8160247

Mark deprecated javax.security.cert APIs with forRemoval=true

    Details

      Description

      JSSE 1.0.x was an unbundled release that provided JDK 1.2/1.3 with SSL/TLS, and was eventually bundled in JDK 1.4.

      The com.sun.net.ssl APIs were deprecated in 1.4, but were left for backwards compatibility with JSSE 1.0.x applications. They were never part of the 1.4+ API set.

      The javax.security.cert APIs were deprecated in 1.9 but have had the following warning (since 1.4?) in the description of each class:

          Note: The classes in the package javax.security.cert exist for compatibility with earlier versions of the Java Secure Sockets Extension (JSSE).
          New applications should instead use the standard Java SE certificate classes located in java.security.cert.

      Since these earlier versions of JSSE are no longer maintained or supported, there is no reason to retain these packages for compatibility and they should be removed in a future release.

      Methods that use the javax.security.cert APIs should be marked with forRemoval=true too.

      The removal of this internal package will be addressed in JDK-8215430. While the public APIs update will be addressed in this RFE.

      See JDK-8157712, JDK-8161898 and JDK-8215430.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                xuelei Xue-Lei Fan
                Reporter:
                xuelei Xue-Lei Fan
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: