Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8161947

runtime/Unsafe/GetUnsafe.java is failing on jdk9/dev

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      b131

      Description

      The test runtime/Unsafe/GetUnsafe.java is failing because JDK-8161129 updated the Unsafe.getUnsafe method to remove the calling class loader check, since Jigsaw will enforce access control.

      The test is no longer relevant and can be deleted. There already exists a test, sun/misc/Safe.java, located in the JDK repo test area that tests sun.misc.Unsafe.getUnsafe (the test name could arguably be better named).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                psandoz Paul Sandoz
                Reporter:
                amurillo Alejandro Murillo
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: