Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8162527

[JAXP] XSLT: Investigate why bumping the default class file version to 49 (Java 5.0) or higher for bytecode generation doesn't work.

    Details

    • Type: Enhancement
    • Status: Open
    • Priority: P4
    • Resolution: Unresolved
    • Affects Version/s: 9
    • Fix Version/s: None
    • Component/s: xml
    • Labels:
      None

      Description

      While implementing JDK-8153082 we tried to bump the default class file version for byte code generation in GenClass,java to Java 1.5.0 (49) some tests (in particular SAXTFactoryTest) started failing. It is not clear what in those tests is not compatible with Java 5 class file version. This should be investigated to understand if we could bump the default class file version of the XSLT compiler to at least 5.0 (49).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                joehw Joe Wang
                Reporter:
                dfuchs Daniel Fuchs
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: