Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8164639

Configure PKCS11 tests to use user-supplied NSS libraries

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 11
    • Component/s: security-libs
    • Labels:

      Backports

        Description

        The PKCS11 tests that depend on NSS can automatically locate a version of the NSS libraries. Unfortunately that version may lag the latest version or may lack a required feature or bug fix.

        This enhancement enables users to override the default NSS libraries that are used by those tests. It allows testers the flexibility to supply a specific version of NSS that differs from the one available by default.

        If the NSS libraries cannot be located then the PKCS11 test is skipped.

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  jjiang John Jiang
                  Reporter:
                  vinnie Vincent Ryan
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: