Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8166425

Select the suitable provider that supports a protocol version

    XMLWordPrintable

    Details

      Description

      The PKCS11 library will not support SSLv3 since Solaris 12. If SunPKCS11 is preferred, and a client request to negotiate SSL 3.0, the JSSE implementation is not able to select the underlying provider properly. It would be nice if we can detect the crypto provider ability and select the provider properly.

        Attachments

          Activity

            People

            Assignee:
            valeriep Valerie Peng
            Reporter:
            xuelei Xue-Lei Fan
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: