Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8166461

Deprecate UseAutoGCSelectPolicy

    Details

    • Subcomponent:
      gc
    • Resolved In Build:
      b143

      Description

      The current implementation of UseAutoGCSelectPolicy selects between CMS (the low pause GC) and G1 (the default GC). CMS is being deprecated in favor of G1 (as the new low pause collector). It does not make much sense to have UseAutoGCSelectPolicy select between two low pause collectors since the original intent was to select between the throughput collector and the low pause collector.

      The risk that this change will introduce a bug is very low.

      The change is this 1 line change that adds UseAutoGCSelectPolicy to a list of flags deprecated in jdk9.

       --- a/src/share/vm/runtime/arguments.cpp
      +++ b/src/share/vm/runtime/arguments.cpp
      @@ -381,6 +381,7 @@
         // --- Non-alias flags - sorted by obsolete_in then expired_in:
         { "MaxGCMinorPauseMillis", JDK_Version::jdk(8), JDK_Version::undefined(), JDK_Version::undefined() },
         { "UseParNewGC", JDK_Version::jdk(9), JDK_Version::undefined(), JDK_Version::jdk(10) },
      + { "UseAutoGCSelectPolicy", JDK_Version::jdk(9), JDK_Version::undefined(), JDK_Version::jdk(10) },
         { "ConvertSleepToYield", JDK_Version::jdk(9), JDK_Version::jdk(10), JDK_Version::jdk(11) },
         { "ConvertYieldToSleep", JDK_Version::jdk(9), JDK_Version::jdk(10), JDK_Version::jdk(11) },

      plus a test for the change. If approved by 7Oct2016, it could be completed by 14Oct2016.

        Attachments

          Activity

            People

            • Assignee:
              sangheki Sangheon Kim
              Reporter:
              jmasa Jon Masamitsu (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved: