Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8169740

Need JAXB 2.3 to be JDK 7 compatible

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: xml
    • Labels:
      None
    • Subcomponent:
    • CPU:
      generic
    • OS:
      generic

      Description

      In order to support JDK 9 we are moving to version 2.3 of jaxb however we still have consumers of our software who are still using JDK 7. Some of classes in the jaxb 2.3 jars provided are compiled at a JDK 8 level which results in exceptions such as:
      java.lang.UnsupportedClassVersionError: com/sun/istack/Pool : Unsupported major.minor version 52.0

        Attachments

          Activity

            People

            • Assignee:
              rgrigoriadi Roman Grigoriadi (Inactive)
              Reporter:
              rgenna Russell Genna
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: