Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8171137

[AOT] Avoid warning: -Xint is not compatible with AOT (switching AOT off)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b150
    • CPU:
      x86
    • OS:
      linux
    • Verification:
      Verified

      Description

      You need to compile and install AOT libraries to use AOT.
      If there is no AOT libs UseAOT flag will be set to 'false'.
      But we have to check for AOT libraries installed into JDK first and that code under UseAOT. So we decided to have initial value 'true'.

      But we should not produce this warning message with -Xint in default run.
      And show it only when there are AOT libraries and only with PrintAOT flag.
      It effect the default JVM output and may affect other tests.

        Attachments

          Activity

            People

            • Assignee:
              kvn Vladimir Kozlov
              Reporter:
              kvn Vladimir Kozlov
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: