Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8171859

Configure check for modular boot jdk needs to be updated

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: infrastructure
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b151

      Description

      JDK-8168935 changes the --patch-module option to emit a warning if the module is unknown, consistent with other --add-* options.

      $ java --patch-module foo=bar
      WARNING: Unknown module: foo specified in --patch-module

      The configure script needs to be updated to filter this warning:

       $ECHO "Check if jvm arg is ok: --patch-module foo=bar" >&5
        $ECHO "Command: $JAVA --patch-module foo=bar -version" >&5
        OUTPUT=`$JAVA --patch-module foo=bar -version 2>&1`
        FOUND_WARN=`$ECHO "$OUTPUT" | $GREP -i warn`
        FOUND_VERSION=`$ECHO $OUTPUT | $GREP " version \""`
        if test "x$FOUND_VERSION" != x && test "x$FOUND_WARN" = x; then
          dummy="$dummy --patch-module foo=bar"
          JVM_ARG_OK=true
        else
          $ECHO "Arg failed:" >&5
          $ECHO "$OUTPUT" >&5
          JVM_ARG_OK=false
        fi

        Attachments

          Activity

            People

            • Assignee:
              erikj Erik Joelsson
              Reporter:
              mchung Mandy Chung
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: