Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8172219

Allow compiling without GTK 3.0 being installed

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: javafx
    • Labels:

      Description

      After JDK-8163496 on Linux GTK 3.0 must be installed despite there being conditionals in the scripts to compile if it is not. There is a simple fix:

      diff -r d59805c7ee03 buildSrc/linux.gradle
      --- a/buildSrc/linux.gradle Tue Jan 03 10:39:05 2017 -0800
      +++ b/buildSrc/linux.gradle Tue Oct 20 09:23:23 2015 -0700
      @@ -181,7 +181,7 @@
           logger.info("Building libglassgtk3")
           LINUX.glass.variants += "glassgtk3"
       } else {
      - logger.warning("NOT Building libglassgtk3")
      + logger.info("NOT Building libglassgtk3")
       }
       
       FileTree ft_gtk_launcher = fileTree("${project(":graphics").projectDir}/src/main/native-glass/gtk/") {

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ddhill David Hill (Inactive)
                Reporter:
                cbensen Chris Bensen (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: