Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8172881

AArch64: assertion failure: the int pressure is incorrect

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b156
    • CPU:
      aarch64
    • OS:
      linux
    • Verification:
      Not verified

      Backports

        Description

        The jtreg tests
        hotspot/test/compiler/unsafe/JdkInternalMiscUnsafeAccessTestFloat.java
        hotspot/test/compiler/unsafe/JdkInternalMiscUnsafeAccessTestDouble.java
        failed on AArch64 with option "-Xcomp".

        $ jtreg -othervm -a -ea -esa -va -ignore:quiet -timeoutFactor:8 -testjdk:./images/jdk/ -concurrency:auto -server -vmoptions:"-Xcomp" ~/Work/jdk/jdk9/gerrit/hotspot/test/compiler/unsafe/JdkInternalMiscUnsafeAccessTestFloat.java

        # To suppress the following error report, specify this argument
        # after -XX: or in .hotspotrc: SuppressErrorAt=/ifg.cpp:760
        #
        # A fatal error has been detected by the Java Runtime Environment:
        #
        # Internal Error (/home/ninjia02/jdk/jdk9/gerrit/hotspot/src/share/vm/opto/ifg.cpp:760), pid=12233, tid=12296
        # assert(int_pressure.current_pressure() == count_int_pressure(liveout)) failed: the int pressure is incorrect
        #
        # JRE version: OpenJDK Runtime Environment (9.0) (fastdebug build 9-internal+0-adhoc.ninjia02.gerrit)
        # Java VM: OpenJDK 64-Bit Server VM (fastdebug 9-internal+0-adhoc.ninjia02.gerrit, compiled mode, compressed oops, g1 gc, linux-aarch64)
        # Core dump will be written. Default location: Core dumps may be processed with "/usr/share/apport/apport %p %s %c %P" (or dumping to /home/ninjia02/jdk/jdk9/build-fastdebug/JTwork/scratch/0/core.12233)
        #
        # An error report file with more information is saved as:
        # /home/ninjia02/jdk/jdk9/build-fastdebug/JTwork/scratch/0/hs_err_pid12233.log
        #
        # Compiler replay data is saved as:
        # /home/ninjia02/jdk/jdk9/build-fastdebug/JTwork/scratch/0/replay_pid12233.log
        #
        # If you would like to submit a bug report, please visit:
        # http://bugreport.java.com/bugreport/crash.jsp
        #

        This may be caused by incorrect reg use of get_and_setI

          Activity

          thartmann Tobias Hartmann added a comment -
          ILW = Assert in compiler, arch64 only, exclude compilation = HMM = P2
          thartmann Tobias Hartmann added a comment -
          Hi [~njian], please add the hs_err file to the bug. Do you plan to fix the problem? If not, please un-assign from yourself.
          njian Ningsheng Jian added a comment -
          Yang Zhang (yang.zhang@linaro.org) is working on this.
          hgupdate HG Updates added a comment -
          URL: http://hg.openjdk.java.net/jdk9/hs/hotspot/rev/bfa8e4b0d4e2
          User: aph
          Date: 2017-01-26 12:11:31 +0000
          hgupdate HG Updates added a comment -
          URL: http://hg.openjdk.java.net/jdk9/jdk9/hotspot/rev/bfa8e4b0d4e2
          User: lana
          Date: 2017-02-08 19:29:31 +0000

            People

            • Assignee:
              aph Andrew Haley
              Reporter:
              njian Ningsheng Jian
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: