Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8175091

Mark the deprecated java.security.{Certificate,Identity,IdentityScope,Signer} APIs with forRemoval=true

    Details

      Description

      The java.security.{Certificate, Identity, IdentityScope, Signer} classes have been deprecated since 1.2 and superseded by java.security.cert, java.security.KeyStore and related classes since 1.2. It is no longer necessary to retain these classes and they should be removed in a future release.

        Issue Links

          Activity

          Hide
          mullan Sean Mullan added a comment -
          These APIs were originally marked for removal in JDK 9 but the change was backed out before 9 was released because some external projects needed more time to remove the dependencies. Marking them for removal is being re-targeted to JDK 10.
          Show
          mullan Sean Mullan added a comment - These APIs were originally marked for removal in JDK 9 but the change was backed out before 9 was released because some external projects needed more time to remove the dependencies. Marking them for removal is being re-targeted to JDK 10.
          Hide
          hgupdate HG Updates added a comment -
          URL: http://hg.openjdk.java.net/jdk/jdk/rev/28096878fae5
          User: mullan
          Date: 2017-11-14 13:29:21 +0000
          Show
          hgupdate HG Updates added a comment - URL: http://hg.openjdk.java.net/jdk/jdk/rev/28096878fae5 User: mullan Date: 2017-11-14 13:29:21 +0000

            People

            • Assignee:
              mullan Sean Mullan
              Reporter:
              mullan Sean Mullan
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: