Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8175813

PPC64: "mbind: Invalid argument" when -XX:+UseNUMA is used

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 10
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
      gc
    • Resolved In Build:
      master
    • CPU:
      ppc
    • OS:
      linux

      Backports

        Description

        The JVM code used to discover which numa nodes it can bind assumes that nodes are consecutive and tries to bind from 0 to numa_max_node(), i.e. 0 to the highest node number available on the system. However, at least on PPC64 that assumption is not always true. For instance, the following numa
        topology:

        available: 4 nodes (0-1,16-17)
        node 0 cpus: 0 8 16 24 32
        node 0 size: 130706 MB
        node 0 free: 145 MB
        node 1 cpus: 40 48 56 64 72
        node 1 size: 0 MB
        node 1 free: 0 MB
        node 16 cpus: 80 88 96 104 112
        node 16 size: 130630 MB
        node 16 free: 529 MB
        node 17 cpus: 120 128 136 144 152
        node 17 size: 0 MB
        node 17 free: 0 MB
        node distances:
        node 0 1 16 17
        0: 10 20 40 40
        1: 20 10 40 40
        16: 40 40 10 20
        17: 40 40 20 10

        Also, some nodes can also be present in the topology but contain no memory (a memory-less node in libnuma terms).

          Issue Links

            Activity

            dholmes David Holmes added a comment -
            This is a duplicate of JDK-8163796. One of them should be closed.
            gromero Gustavo Romero added a comment -
            Hi @dholmes. The issue reported by Sangheon on x64 seems different in its root cause from the one I reported on PPC64 since, AFAICS, numa nodes on x64 are always consecutive. If so, is it really a dup?
            dholmes David Holmes added a comment -
            You are right. There can be many reasons for EINVAL from mbind and the two underlying causes seem likely to be different.
            hgupdate HG Updates added a comment -
            URL: http://hg.openjdk.java.net/jdk10/hs/hotspot/rev/842ba4a88947
            User: dholmes
            Date: 2017-05-07 21:53:55 +0000
            hgupdate HG Updates added a comment -
            URL: http://hg.openjdk.java.net/jdk10/jdk10/hotspot/rev/842ba4a88947
            User: jwilhelm
            Date: 2017-08-18 18:01:35 +0000

              People

              • Assignee:
                gromero Gustavo Romero
                Reporter:
                gromero Gustavo Romero
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: