Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8176541

XML deprecation "since" values should use 1.x version form for 1.8 and earlier

    Details

    • Subcomponent:
    • Resolved In Build:
      b162
    • Verification:
      Not verified

      Backports

        Description

        The jdeprscan output from current JDK 9 builds shows the following:

        @Deprecated(since="5") class org.xml.sax.helpers.ParserFactory
        @Deprecated(since="7") javax.xml.stream.XMLEventFactory javax.xml.stream.XMLEventFactory.newInstance(java.lang.String,java.lang.ClassLoader)
        @Deprecated(since="7") javax.xml.stream.XMLInputFactory javax.xml.stream.XMLInputFactory.newFactory()
        @Deprecated(since="7") javax.xml.stream.XMLInputFactory javax.xml.stream.XMLInputFactory.newInstance(java.lang.String,java.lang.ClassLoader)
        @Deprecated(since="7") javax.xml.stream.XMLInputFactory javax.xml.stream.XMLOutputFactory.newInstance(java.lang.String,java.lang.ClassLoader)
        @Deprecated(since="5") interface org.xml.sax.AttributeList
        @Deprecated(since="5") interface org.xml.sax.DocumentHandler
        @Deprecated(since="5") interface org.xml.sax.Parser

        The JEP 277 rule for JDK versions in the "since" value is that it should correspond to the JDK version in use at the time, usually "1.2" through "1.8", but then changing to "9" only in JDK 9. These deprecations should be adjusted to have "1.5" and "1.7" for their "since" values.

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  joehw Joe Wang
                  Reporter:
                  smarks Stuart Marks
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: