Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8176830

JDK 9 dependencys in JREInfo and JfxRuntime

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 10
    • Fix Version/s: 10
    • Component/s: deploy
    • Labels:
    • Resolved In Build:
      b23
    • OS:
      generic

      Description

      There is code in JREInfo.isValid() that is specific to JDK9:
                      platform.compareTo("1.6") >=0 &&
                      platform.compareTo("9") <= 0 &&
      This implements the requirement that for deployment in JDK9, only jres of the 1.6.0, 1.7.0, 1.8.0 and 9 families are valid.
      For JDK10 this should be:
                      platform.compareTo("1.7") >=0 &&
                      platform.compareTo("10") <= 0 &&
      ie: only 1.7.0, 1.8.0, JDK9, and JDk10 are valid.

      Secondly, there is code in JfxRuntime.runtimeForJRE():
              } else if (product.startsWith("9")) {
                  version = noDash(product);
                  path = null; // no javafx.jar in JDK9
              }
      this needs to be:
              } else if (product.startsWith("9") || product.startsWith("10")) {
                  version = noDash(product);
                  path = null; // no javafx.jar in JDK9
              }
      or we will think there is no JFX in JDk10.

        Activity

        Hide
        herrick Andy Herrick added a comment -
        Show
        herrick Andy Herrick added a comment - Crucible review: https://java.se.oracle.com/code/cru/CR-JDK10CLIENT-1

          People

          • Assignee:
            herrick Andy Herrick
            Reporter:
            herrick Andy Herrick
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: