Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8177048

javadoc should support -version and/or --version

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 10
    • Component/s: tools
    • Labels:
      None

      Description

      jdk9 javac supports -version and --version (and -fullversion), and its sibling program javadoc should do likewise. Both programs should support the same set of version flags, with equivalent output, probably implemented via shared code.

      javadoc: error - invalid flag: --version

      $ javac -fullversion
      javac full version "9-ea+161"

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              pmuthuswamy Priya Lakshmi Muthuswamy (Inactive)
              Reporter:
              martin Martin Buchholz
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: