Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8178347

Process and ProcessHandle getPid method name inconsistency

    Details

    • Subcomponent:
    • Introduced In Version:
      9
    • Resolved In Build:
      b166
    • Verification:
      Verified

      Backports

        Description

        The getPid methods (new in JDK 9) in ProcessHandle and Process use the old bean style names and are inconsistent with other method names added to those apis.

        The 'getPid' method should be renamed to simply 'pid' to be consistent in style.
        The change is straightforward and mechanical.

        The issue was mentioned in openjdk mail: http://mail.openjdk.java.net/pipermail/core-libs-dev/2017-April/047100.html

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  rriggs Roger Riggs
                  Reporter:
                  rriggs Roger Riggs
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: