Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8178951

"Module ... does not exist" is printed on console

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 9, 10
    • Fix Version/s: 10
    • Component/s: deploy
    • Labels:
    • Environment:

      java version "9-ea"
      Java(TM) SE Runtime Environment (build 9-ea+164)
      Java HotSpot(TM) 64-Bit Server VM (build 9-ea+164, mixed mode)

      Description

      TESTED ENVIRONMENT.

      1. Windows 7 64 bit.
      2. Download and install 164 promoted build from artifacts and set JAVA_HOME and PATH environmental variables accordingly.
      3. Installed Wix and Inno Setup on Operating system.
      4. Download Ant 1.9.7 and set ANT_HOME and PATH environmental variables accordingly.


      STEPS TO REPRODUCE

      1. please find the attachment for source code in "bug.zip", download "bug.zip" and extract to system.

      2. Navigate to the folder "bug" and execute the following commands at command line.

      javac --module-path "%JAVA_HOME%"\jmods -d bin\custom.util src\custom.util\module-info.java src\custom.util\testapp\util\Util.java

      javac --module-path "%JAVA_HOME%"\jmods;bin -d bin\com.greetings src\com.greetings\module-info.java src\com.greetings\com\greetings\App1.java

      javapackager -deploy -verbose -outdir bundles -outfile test -native exe --module-path C:\PROGRA~1\Java\jdk-9\jmods;bin --module com.greetings/com.greetings.App1 -name SimpleTest

      3. please find the attachment "module_not_found.png" for screenshot of error.

      4. Application seems to be working fine by installing setup file "*.exe" from bundles folder.

      NOTE:

      1. I can see the same error on console when executed through JAVA_API and ANT interface and also irrespective of end product format i.e. (*.exe, *.msi, win_app)
      2. I don't see any error like "Module com.greetings does not exist" when module is used as Jmod or ModularJar, error is seen only when module is used as exploded module.

      it looks like logger issue to me. please check it once.

        Attachments

          Activity

            People

            • Assignee:
              vdrozdov Victor Drozdov (Inactive)
              Reporter:
              rgangadhar Ramesh Gangadhar
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: