Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8179261

Replace always_update_barrier_set with proper API in BarrierSet

    Details

    • Type: Enhancement
    • Status: Closed
    • Priority: P4
    • Resolution: Withdrawn
    • Affects Version/s: 10
    • Fix Version/s: 10
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
      gc
    • CPU:
      generic
    • OS:
      generic

      Description

      There's a global variable always_update_barrier_set that directs whether or not oop stores and its GC barriers require a release membar. It is only used for CMS. It should be refactored into a proper API in BarrierSet, so that this GC specific hook can be avoided in shared code, and instead be implemented by GCs that need it.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                rkennke Roman Kennke
                Reporter:
                rkennke Roman Kennke
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: