Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8180307

Update JDK 9 Required Cipher Algorithms

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b171
    • Verification:
      Not verified

      Backports

        Description

        The following new required Cipher algorithms were approved as part of JDK-8015388:

            AES/GCM/NoPadding (128)
            AES/GCM/PKCS5Padding (128)

        "AES/GCM/PKCS5Padding (128)" should be removed from this list. PKCS5Padding is not a valid padding for AES. There is a bug in the JDK in which the SunJCE provider accepts PKCS5Padding as a valid padding, but it should throw a NoSuchAlgorithmException (see JDK-8180392).

        Also, the required algorithms for JDK 9 were accidentally omitted for the Cipher class as part of JDK-8015388. The following should be added to the implementation requirements of the class summary:

            AES/GCM/NoPadding (128)

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                mullan Sean Mullan
                Reporter:
                mullan Sean Mullan
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: