Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8181922

Provide media support for libav version 57

    Details

    • Subcomponent:
    • CPU:
      x86_64
    • OS:
      linux_ubuntu

      Backports

        Description

        A DESCRIPTION OF THE REQUEST :
        This is a follow-up to JDK-8150503 and an upstream bug report for https://josm.openstreetmap.de/ticket/2089

        As per Quality Outreahc, please add josm-found label to this report.

        We're using JavaFX Media to play MP3 files. Ubuntu 16.10 and 17.04 use libavcodec 57 (https://packages.ubuntu.com/zesty/libavcodec57).

        It appears OpenJFX does not support libav 57 out of the box as we needed to create a symilnk to /usr/lib/x86_64-linux-gnu/libavcodec.so to make the MP3 playback work.

        Support for libav 57 should be added.

        JUSTIFICATION :
        To make OpenJFX able to play MP3 on latest version of Ubuntu.

        EXPECTED VERSUS ACTUAL BEHAVIOR :
        EXPECTED -
        OpenJFX recognizes libavcodec57
        ACTUAL -
        Package libavcodec57 not recognized

        CUSTOMER SUBMITTED WORKAROUND :
        create symlink to /usr/lib/x86_64-linux-gnu/libavcodec.so

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  almatvee Alexander Matveev
                  Reporter:
                  webbuggrp Webbug Group
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  8 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: