Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8182148

jdk.incubator.httpclient unnecessarily requires java.base

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P4
    • Resolution: Duplicate
    • Affects Version/s: 9, 10
    • Fix Version/s: tbd_minor
    • Component/s: core-libs
    • Labels:

      Description

      module jdk.incubator.httpclient {
          requires java.base;
          exports jdk.incubator.http;
      }
      "requires java.base" is unnecessary, and it's confusing why jdk.incubator.httpclient requires java.base while other modules don't.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                chegar Chris Hegarty
                Reporter:
                mli Hamlin Li (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: