Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8184069

A fatal error has been detected by the Java Runtime Environment

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P4
    • Resolution: Incomplete
    • Affects Version/s: 6u43
    • Fix Version/s: None
    • Component/s: client-libs
    • Labels:
    • Subcomponent:
    • CPU:
      x86
    • OS:
      other

      Description

      FULL PRODUCT VERSION :
      # JRE version: 6.0_26-b03

      FULL OS VERSION :
      window 10 64bit creater update

      EXTRA RELEVANT SYSTEM CONFIGURATION :
      CPU:total 2 (2 cores per cpu, 1 threads per core) family 6 model 60 stepping 3, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1, sse4.2, popcnt

      Memory: 4k page, physical 7264280k(4917528k free),

      A DESCRIPTION OF THE PROBLEM :
      #
      # A fatal error has been detected by the Java Runtime Environment:
      #
      # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x7c350440, pid=6328, tid=4888
      #
      # JRE version: 6.0_26-b03
      # Java VM: Java HotSpot(TM) Client VM (20.1-b02 mixed mode windows-x86 )
      # Problematic frame:
      # C [msvcr71.dll+0x10440]
      #
      # If you would like to submit a bug report, please visit:
      # http://java.sun.com/webapps/bugreport/crash.jsp
      # The crash happened outside the Java Virtual Machine in native code.
      # See problematic frame for where to report the bug.
      #

      --------------- T H R E A D ---------------

      Current thread (0x2dbaac00): JavaThread "Swing-Shell" daemon [_thread_in_native, id=4888, stack(0x2dde0000,0x2de00000)]

      siginfo: ExceptionCode=0xc0000005, reading address 0x00000000

      Registers:
      EAX=0x00000000, EBX=0x1d928dc8, ECX=0x00000000, EDX=0x0063d898
      ESP=0x2ddff658, EBP=0x2ddff7c4, ESI=0x2ddff674, EDI=0x2dbaad28
      EIP=0x7c350440, EFLAGS=0x00210246

      Top of Stack: (sp=0x2ddff658)
      0x2ddff658: 6d1694aa 00000000 0068a9b8 6d169d49
      0x2ddff668: 0068a9b8 2dbaac00 1d928dc8 00000000
      0x2ddff678: 00000000 2ddff6b8 1d4f2450 00000000
      0x2ddff688: 00000000 2ddff68c 1d4fa050 2ddff6b8
      0x2ddff698: 1d4fd020 00000000 1d4fa078 00000000
      0x2ddff6a8: 2ddff6b4 2ddff6dc 024c2e21 00000000
      0x2ddff6b8: 0474b080 2ddff6bc 1d4efeab 2ddff6fc
      0x2ddff6c8: 2ddff6f8 6d8a2ac6 2dbaac00 2d822470

      Instructions: (pc=0x7c350440)
      0x7c350420: 8b 4c 24 04 8b 54 24 08 66 8b 02 66 89 01 41 41
      0x7c350430: 42 42 66 85 c0 75 f1 8b 44 24 04 c3 8b 44 24 04
      0x7c350440: 66 8b 08 40 40 66 85 c9 75 f6 2b 44 24 04 d1 f8
      0x7c350450: 48 c3 55 8b ec 51 e8 db 91 ff ff 8b 48 64 3b 0d


      Register to memory mapping:

      EAX=0x00000000 is an unknown value
      EBX=0x1d928dc8 is an oop
      {method}
       - klass: {other class}
      ECX=0x00000000 is an unknown value
      EDX=0x0063d898 is an unknown value
      ESP=0x2ddff658 is pointing into the stack for thread: 0x2dbaac00
      EBP=0x2ddff7c4 is pointing into the stack for thread: 0x2dbaac00
      ESI=0x2ddff674 is pointing into the stack for thread: 0x2dbaac00
      EDI=0x2dbaad28 is an unknown value


      Stack: [0x2dde0000,0x2de00000], sp=0x2ddff658, free space=125k
      Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
      C [msvcr71.dll+0x10440] wcslen+0x4
      j sun.awt.shell.Win32ShellFolder2.access$800(JJI)Ljava/lang/String;+4
      j sun.awt.shell.Win32ShellFolder2$14.call()Ljava/lang/String;+15
      j sun.awt.shell.Win32ShellFolder2$14.call()Ljava/lang/Object;+1
      j java.util.concurrent.FutureTask$Sync.innerRun()V+30
      j java.util.concurrent.FutureTask.run()V+4
      j java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Ljava/lang/Runnable;)V+59
      j java.util.concurrent.ThreadPoolExecutor$Worker.run()V+28
      j sun.awt.shell.Win32ShellFolderManager2$ComInvoker$3.run()V+7
      j java.lang.Thread.run()V+11
      v ~StubRoutines::call_stub
      V [jvm.dll+0xfae4b]
      V [jvm.dll+0x18c531]
      V [jvm.dll+0xfaff1]
      V [jvm.dll+0xfb04b]
      V [jvm.dll+0xb56b9]
      V [jvm.dll+0x1190d4]
      V [jvm.dll+0x1411ac]
      C [msvcr71.dll+0x9565] endthreadex+0xa0
      C [KERNEL32.DLL+0x18744] BaseThreadInitThunk+0x24
      C [ntdll.dll+0x6587d] RtlGetAppContainerNamedObjectPath+0xfd
      C [ntdll.dll+0x6584d] RtlGetAppContainerNamedObjectPath+0xcd

      Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
      j sun.awt.shell.Win32ShellFolder2.getDisplayNameOf(JJI)Ljava/lang/String;+0
      j sun.awt.shell.Win32ShellFolder2.access$800(JJI)Ljava/lang/String;+4
      j sun.awt.shell.Win32ShellFolder2$14.call()Ljava/lang/String;+15
      j sun.awt.shell.Win32ShellFolder2$14.call()Ljava/lang/Object;+1
      j java.util.concurrent.FutureTask$Sync.innerRun()V+30
      j java.util.concurrent.FutureTask.run()V+4
      j java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Ljava/lang/Runnable;)V+59
      j java.util.concurrent.ThreadPoolExecutor$Worker.run()V+28
      j sun.awt.shell.Win32ShellFolderManager2$ComInvoker$3.run()V+7
      j java.lang.Thread.run()V+11
      v ~StubRoutines::call_stub



      THE PROBLEM WAS REPRODUCIBLE WITH -Xint FLAG: Did not try

      THE PROBLEM WAS REPRODUCIBLE WITH -server FLAG: Did not try

      REPRODUCIBILITY :
      This bug can be reproduced always.

        Issue Links

          Activity

          pardesha Pardeep Sharma added a comment -
          This issue is reported against JDK 6u43 with Windows 10 Creator update.
          This is likely fixed in JDK-8179014 which has a fix for JDK 8u and 9 ea.
          Writing back to submitter requesting to confirm back the status with ea builds of 8u152 and 9.
          pardesha Pardeep Sharma added a comment -
          Closing this as incomplete as we haven't received any update from submitter. If we receive a response in future, may reopen this report.

            People

            • Assignee:
              pardesha Pardeep Sharma
              Reporter:
              webbuggrp Webbug Group
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: