Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8184338

switch minimum supported gcc version to 4.7

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 10
    • Fix Version/s: 10
    • Component/s: infrastructure
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b16

      Description

      Currently the toolchain related parts in the OpenJDK 10 configure environment checkon Linux for minimum gcc 4.3. However the compiler flags currently used do not work any more with gcc 4.3 (one example is -fno-var-tracking-assignments in the HS build).
      Change to minimum gcc 4.8 because this is a more modern und suitable version for OpenJDK 10.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mbaesken Matthias Baesken
              Reporter:
              mbaesken Matthias Baesken
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: