Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8185656

[AArch64] Fix for 8154537 was missing one file

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P4
    • Resolution: Duplicate
    • Affects Version/s: 9, 10
    • Fix Version/s: 10
    • Component/s: hotspot
    • Labels:

      Description

      I'm looking at the webrev in
      http://cr.openjdk.java.net/~roland/8154537/webrev.00/ and I see the
      the changes were made to aarch64.ad but not to ad_aarch64.m4. This is
      problematic because some .m4 files are used to generate the .ad file,
      and if anyone regenerates the .ad file the bug will regress.

      I think this is the change we need to make. It won't affect generated
      code at all, but it is something of a ticking bomb.

      http://cr.openjdk.java.net/~aph/8185656.patch

        Issue Links

          Activity

          rraghavan Rahul Raghavan added a comment -
          Hi [~roland], please note assigning this task to you for now, since you worked for 8154537. Please re-assign if any issues. Thanks.
          rraghavan Rahul Raghavan added a comment -
          ILW = possible 8154537-some integer rotate instructions not emitted; No failure as of now, possible regression if .ad file regenerated, only for aarch64; No Workaround = MLH = P4

            People

            • Assignee:
              roland Roland Westrelin
              Reporter:
              aph Andrew Haley
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: