Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8186478

[JVMCI] rename HotSpotResolvedJavaMethod#setNotInlineableOrCompileable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9, 10
    • Fix Version/s: 10
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b33

      Description

      This method should be renamed to setNotInlinableOrCompilable for better consistency with existing OpenJDK source. Grepping through the sources available from http://hg.openjdk.java.net/jdk10/hs:

      dsimon@kruger-4 ~/j/open> ag -i inlineable | grep -v setNotInlineableOrCompileable | wc -l
           107
      dsimon@kruger-4 ~/j/open> ag -i inlinable | grep -v setNotInlineableOrCompileable | wc -l
            24
      dsimon@kruger-4 ~/j/open> ag -i compileable | grep -v setNotInlineableOrCompileable | wc -l
             3
      dsimon@kruger-4 ~/j/open> ag -i compilable | grep -v setNotInlineableOrCompileable | wc -l
           585

      Based purely on these frequencies, we could rename to setNotInlineableOrCompilable but that looks internally inconsistent (why drop e from one word and not the other?).

        Attachments

          Activity

            People

            • Assignee:
              dnsimon Douglas Simon
              Reporter:
              dnsimon Douglas Simon
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: