Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8188654

Upgrade FX build to use gradle 4.3

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 10
    • Fix Version/s: 10
    • Component/s: javafx
    • Labels:

      Description

      In order to use a post-JDK 9 bootjdk we need to upgrade gradle, since gradle 3.x does not recognize anything > 9 as a valid JDK version.

      gradle 4.1 supports JDK 9 and also recognizes "10" as a valid version. Unfortunately, even gradle 4.1 will fail when/if the Java version string is changed to 18.3. See the comments at the end of:

      https://github.com/gradle/gradle/issues/2454

      which is the bug that they used to add support for a version of Java 10. So we will likely need to move to something > 4.1 when the (yet-to-be-filed) bug is fixed by the gradle team.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kcr Kevin Rushforth
                Reporter:
                kcr Kevin Rushforth
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: