Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8188764

Obsolete AssumeMP and then remove all support for non-MP builds

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 11
    • Fix Version/s: 12
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      b14

      Description

      We propose to only build for MP platforms. AssumeMP (which defaults to true since 18.3) is hardwired to true; os::is_MP is always true, and we can elide all code and code generation that provides for a non-MP path.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                dholmes David Holmes
                Reporter:
                dholmes David Holmes
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: