Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8189336

javac Tools Reference: Document -Xlint:requires-automatic

    Details

    • Subcomponent:
    • CPU:
      generic

      Description

      A DESCRIPTION OF THE REQUEST :
      http://docs.oracle.com/javase/9/tools/javac.htm#JSWOR627 is supposed to list all valid -Xlint values but it neglects to mention "requires-automatic" and "requires-transitive-automatic" added by https://bugs.openjdk.java.net/browse/JDK-8178011.

      These flags are present in JDK 9 GA.

      JUSTIFICATION :
      Users with non-Java9 dependencies will need to be able to know how to disable the "requires-automatic" warning.


        Attachments

          Activity

            People

            • Assignee:
              cwayne Clifford Wayne
              Reporter:
              webbuggrp Webbug Group
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: