Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8190681

New zlib 1.2.11 doesn't work in Ubuntu

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Duplicate
    • Affects Version/s: 8u152
    • Fix Version/s: None
    • Component/s: core-libs

      Description

      FULL PRODUCT VERSION :
      java version "1.8.0_152"
      Java(TM) SE Runtime Environment (build 1.8.0_152-b16)
      Java HotSpot(TM) 64-Bit Server VM (build 25.152-b16, mixed mode)

      ADDITIONAL OS VERSION INFORMATION :
      Verified with "Ubuntu 16.04.3 LTS x64" and "Ubuntu 14.04.5 LTS"

      A DESCRIPTION OF THE PROBLEM :
      newer zlib 1.2.11 in java 8u152/8u151 doesn't work.

      REGRESSION. Last worked in version 8u151

      STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
      Could be reproducible even with simple tomcat app:

      curl http://localhost:8080/myapp/global.css -H 'Accept-Encoding: gzip' --compressed -o/dev/null ;echo $?
        % Total % Received % Xferd Average Speed Time Time Time Current
                                       Dload Upload Total Spent Left Speed
        0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
      curl: (23) Error while processing content unencoding: invalid block type
      23


      ERROR MESSAGES/STACK TRACES THAT OCCUR :
      Here is the tomcat log:

      java.util.zip.ZipException: invalid block type

      REPRODUCIBILITY :
      This bug can be reproduced always.

      CUSTOMER SUBMITTED WORKAROUND :
      Replace jre/lib/amd64/libzip.so file with one from jdk 8u144

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              psonal Pallavi Sonal (Inactive)
              Reporter:
              webbuggrp Webbug Group
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: