Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8191439

Race in building jdk.rmic.interim

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 10
    • Fix Version/s: 10
    • Component/s: infrastructure
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      b35

      Description

      windows build intermittently fails in mach5:

      jib > Creating support/modules_libs/java.base/jrt-fs.jar
      jib > Error occurred during initialization of boot layer
      jib > java.lang.module.FindException: Error reading module: t:\workspace\build\windows-x64\buildtools\interim_modules\jdk.rmic.interim
      jib > Caused by: java.lang.module.InvalidModuleDescriptorException: Truncated module-info.class
      jib > Gensrc-java.corba.gmk:36: recipe for target '/cygdrive/t/workspace/build/windows-x64/buildtools/corba_tools_classes/_the.BUILD_TOOLS_CORBA_batch' failed
      jib > make[3]: *** [/cygdrive/t/workspace/build/windows-x64/buildtools/corba_tools_classes/_the.BUILD_TOOLS_CORBA_batch] Error 1
      jib > make[3]: *** Waiting for unfinished jobs....
      jib > Compiling 9 files for BUILD_VM_COMPILER_NODEINFO_PROCESSOR
      jib > Creating support/test/failure_handler/timeoutHandler.dll from 1 file(s)
      jib > Note: Some input files use or override a deprecated API.
      jib > Note: Recompile with -Xlint:deprecation for details.
      jib > Note: Some input files use or override a deprecated API.
      jib > Note: Recompile with -Xlint:deprecation for details.
      jib > Note: t:\workspace\open\src\java.corba\share\classes\com\sun\tools\corba\se\idl\Arguments.java uses or overrides a deprecated API that is marked for removal.
      jib > Note: Recompile with -Xlint:removal for details.
      jib > Note: Some input files use unchecked or unsafe operations.
      jib > Note: Recompile with -Xlint:unchecked for details.
      jib > make/Main.gmk:115: recipe for target 'java.corba-gensrc-src' failed
      jib > make[2]: *** [java.corba-gensrc-src] Error 1
      jib > make[2]: *** Waiting for unfinished jobs....

        Activity

        iignatyev Igor Ignatyev created issue -
        dcubed Daniel Daugherty added a comment -
        Saw something similar on OSX:

        jib > Compiling 27 files for BUILD_FAILURE_HANDLER
        jib > Error occurred during initialization of boot layer
        jib > java.lang.module.FindException: Error reading module: /scratch/mesos/slaves/5af44a71-976a-41b7-81de-5773b84ec572-S38414/frameworks/1735e8a2-a1db-478c-8104-60c8b0af87dd-0196/executors/317da363-81d6-4f3f-b70e-57e9bfb47552/runs/f7ec34d0-a15a-4a74-8511-3278fd4f1f1e/workspace/build/macosx-x64-debug/buildtools/interim_modules/jdk.rmic.interim
        jib > Caused by: java.lang.module.InvalidModuleDescriptorException: Truncated module-info.class
        jib > CompileToolsJdk.gmk:74: recipe for target '/scratch/mesos/slaves/5af44a71-976a-41b7-81de-5773b84ec572-S38414/frameworks/1735e8a2-a1db-478c-8104-60c8b0af87dd-0196/executors/317da363-81d6-4f3f-b70e-57e9bfb47552/runs/f7ec34d0-a15a-4a74-8511-3278fd4f1f1e/workspace/build/macosx-x64-debug/buildtools/depend/_the.COMPILE_DEPEND_batch' failed
        jib > make[3]: *** [/scratch/mesos/slaves/5af44a71-976a-41b7-81de-5773b84ec572-S38414/frameworks/1735e8a2-a1db-478c-8104-60c8b0af87dd-0196/executors/317da363-81d6-4f3f-b70e-57e9bfb47552/runs/f7ec34d0-a15a-4a74-8511-3278fd4f1f1e/workspace/build/macosx-x64-debug/buildtools/depend/_the.COMPILE_DEPEND_batch] Error 1
        jib > make[3]: *** Waiting for unfinished jobs....
        iklam Ioi Lam added a comment -
        Truncated module-info.class --- possibly a concurrent build problem?
        rehn Robbin Ehn added a comment - - edited
        ```jib > Compiling 216 files for BUILD_jdk.rmic.interim
        jib > Compiling 31 files for BUILD_JRTFS
        jib > Compiling 950 files for BUILD_VM_COMPILER_MATCH_PROCESSOR
        jib > Compiling 27 files for BUILD_FAILURE_HANDLER
        jib > Error occurred during initialization of boot layer
        jib > java.lang.module.FindException: Error reading module: /scratch/mesos/slaves/5af44a71-976a-41b7-81de-5773b84ec572-S38414/frameworks/1735e8a2-a1db-478c-8104-60c8b0af87dd-0196/executors/317da363-81d6-4f3f-b70e-57e9bfb47552/runs/f7ec34d0-a15a-4a74-8511-3278fd4f1f1e/workspace/build/macosx-x64-debug/buildtools/interim_modules/jdk.rmic.interim
        jib > Caused by: java.lang.module.InvalidModuleDescriptorException: Truncated module-info.class```


        Seem like target "BUILD_jdk.rmic.interim" was not finished, build system timming issue?
        erikj Erik Joelsson made changes -
        Field Original Value New Value
        Affects Version/s 10 [ 16302 ]
        erikj Erik Joelsson made changes -
        Fix Version/s 10 [ 16302 ]
        erikj Erik Joelsson made changes -
        Status New [ 10000 ] Open [ 1 ]
        erikj Erik Joelsson made changes -
        Assignee Erik Joelsson [ erikj ]
        erikj Erik Joelsson added a comment -
        This is caused by CompileInterimLangtools and CompileInterimRmic using the same modular output directory ($(BUILDTOOLS_OUTPUTDIR)/interim_modules/jdk.rmic.interim). We need to either split them into separate directories (preferable) or compile all the interim modules in the same top level target so that all users of these modules depend on all the modules having been compiled instead of just a subset.
        ihse Magnus Ihse Bursie made changes -
        Summary intermittent build failures on windows Race in building jdk.rmic.interim
        erikj Erik Joelsson made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Understanding Fix Understood [ 10001 ]
        hgupdate HG Updates added a comment -
        URL: http://hg.openjdk.java.net/jdk/jdk/rev/7c08e9f96916
        User: erikj
        Date: 2017-12-05 22:15:27 +0000
        hgupdate HG Updates made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolved In Build master [ 18256 ]
        Understanding Fix Understood [ 10001 ]
        Resolution Fixed [ 1 ]
        hgupdate HG Updates made changes -
        Resolved In Build master [ 18256 ] b35 [ 17440 ]

          People

          • Assignee:
            erikj Erik Joelsson
            Reporter:
            iignatyev Igor Ignatyev
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: