Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 11
    • Component/s: security-libs
    • Labels:
      None

      Description

      In JDK 1.8, the following methods of java.lang.SecurityManager were deprecated:

      boolean SecurityManager.checkTopLevelWindow(java.lang.Object)
      void SecurityManager.checkSystemClipboardAccess()
      void SecurityManager.checkAwtEventQueueAccess()
      void SecurityManager.checkMemberAccess(java.lang.Class,int)

      In JDK 9, the methods were marked for removal as part of JDK-8145468.

      Also in JDK 9, the first three methods were changed to check AllPermission by JDK-8029886, and in JDK 10 checkMemberAccess was changed to check AllPermission by JDK-8186535.

      These methods should be removed from a subsequent JDK feature release, possibly JDK 11.

      (Other terminally deprecated SecurityManager APIs that had been deprecated since JDK 1.2 were removed from JDK 10. See JDK-8186535.)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mullan Sean Mullan
                Reporter:
                smarks Stuart Marks
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: