Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8193125

javac should not compile a module if it requires java.base with modifiers

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 10
    • Fix Version/s: 10
    • Component/s: tools
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      b38

      Backports

        Description

        JDK-8182734 has changes to JLS to forbid compiling a module if it requires java.base with modifiers. I believe the following should not compile with `javac --release 10`

        module foo { requires static java.base; }
        module foo { requires transitive java.base; }
        module foo { requires static transitive java.base; }

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                jjg Jonathan Gibbons
                Reporter:
                alanb Alan Bateman
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: