Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8193695

JNLP did not start with the defined version in the JNLP file

    Details

    • Subcomponent:
    • CPU:
      x86
    • OS:
      other

      Description

      FULL PRODUCT VERSION :
      Java Web Start 13.0.0.0
      Mit JRE-Version 10-ea+35 Java HotSpot(TM) 64-Bit Server VM
      JRE-Ablaufdatum: 06.06.18, 00:00

      ADDITIONAL OS VERSION INFORMATION :
      Microsoft Windows [Version 10.0.16299.125]

      A DESCRIPTION OF THE PROBLEM :
      If I start a JNLP application:
      * which is tested with Java 8 and Java 9
      * which is declared to run with Java 8 or Java 9
      * on a system with Java 9 and Java 10 (64 bit) and Java 8 (32 bit)

      It means the application is designed for Java 1.8.* and this is not available. I can only start it with the newest Java version (Java 10)

      EXPECTED VERSUS ACTUAL BEHAVIOR :
      EXPECTED -
      I expected that the application start with Java 9.

      ERROR MESSAGES/STACK TRACES THAT OCCUR :
      Warnung - Nicht verfügbare Java-Version angefordert

      Diese Anwendung ist für eine Version von Java (1.8.*) gedacht, die nicht auf Ihrem
      System installiert ist oder nicht unterstützt wird. Es wird empfohlen, dass Sie die Anwendung
      mit der neuesten Version von Java auf Ihrem Rechner ausführen.

      REPRODUCIBILITY :
      This bug can be reproduced always.

        Attachments

          Activity

            People

            • Assignee:
              herrick Andy Herrick
              Reporter:
              pardesha Pardeep Sharma
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: