Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8198571

[JVMCI] must not install wide vector code unless runtime supports it

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9, 10, 11
    • Fix Version/s: 11
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b07

      Description

      As shown in https://github.com/oracle/graal/issues/303, a bug in a JVMCI compiler can result in vector code being installed even if the runtime doesn't support it. JVMCI should be defensive and raise an exception in this case.

        Attachments

          Activity

            People

            • Assignee:
              dnsimon Douglas Simon
              Reporter:
              dnsimon Douglas Simon
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: