Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8199746

NMT: Breakup overused mtInternal into more fine grained categories.

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Other
    • Affects Version/s: 11
    • Fix Version/s: 13
    • Component/s: hotspot
    • Labels:

      Description

      From Coleen's comment:

      Yay, a quick code review. Is there a better mt tag than mtInternal though? There are too many mtInternal allocations. Can you add mtSafepoint or mtSynchronize (or better name?) and we could have an RFE to make some of these into the same:

      share/runtime/semaphore.hpp:class Semaphore : public CHeapObj<mtInternal> {
      share/runtime/mutex.hpp:class Monitor : public CHeapObj<mtInternal> {
      share/runtime/objectMonitor.cpp: return AllocateHeap(size, mtInternal);
      share/runtime/objectMonitor.cpp: char * knobs = (char *) os::malloc(sz + 2, mtInternal);
      share/runtime/monitorChunk.cpp: _monitors = NEW_C_HEAP_ARRAY(BasicObjectLock, number_on_monitors, mtInternal);

      Or even mtOS so we can move some of the os allocations to this category?

      Why is nothing simple?!

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                zgu Zhengyu Gu
                Reporter:
                zgu Zhengyu Gu
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: