Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8200446

Update minimum boot JDK to 10

    Details

      Description

      This issue proposes to bump the minimum boot JDK to jdk-10+46 which is the recently released GA build. It will also specify 'sourceCompatibility = 10' instead of 9 (1.9) for our source .java files.

      We already use jdk-10+46 to build and test our FX 11 EA bits. Making this the minimum will allow JavaFX developers to take advantage of JDK 10 language features, such as 'var' for local variable type inference from JEP 286 (JDK-8151454) and JDK 10 APIs, if any are needed.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kcr Kevin Rushforth
                Reporter:
                kcr Kevin Rushforth
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: