Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8197943 Unable to use JDWP API in JDK 8 to debug JDK 9 VM
  3. JDK-8203242

Release Note: Unable to use the JDWP API in JDK 8 to debug JDK >=9

    XMLWordPrintable

    Details

    • Subcomponent:
    • Verification:
      Verified

      Description

      The implementation of `VirtualMachineImpl.canGetInstanceInfo()` has been corrected, so it is now able to see JDK JVMs >= JDK 9.

      This correction allows certain debugger agents to operate correctly without any action required from a user (developer).

        Attachments

          Activity

            People

            Assignee:
            scfitch Stephen Fitch
            Reporter:
            scfitch Stephen Fitch
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: