Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8203382

Rename SystemDictionary::initialize_wk_klass to resolve_wk_klass

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b04

      Backports

        Description

        The name is misleading and has caused people to think that classes are initialized (e.g., <clinit> being called) while actually this function only resolves the "well known" classes.

        This function should be renamed to avoid confusion.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                iklam Ioi Lam
                Reporter:
                iklam Ioi Lam
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: