Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8203437

8199370 broke build on linux-ppc64le (w/ GCC 4.8.5.)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 11
    • Fix Version/s: 11
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b15

      Backports

        Description

        libnativeGC05.c:80:19: error: 'pair_getj_mid' may be used uninitialized in this function [-Werror=maybe-uninitialized]
                        j = (*env)->CallIntMethod(env, pair, pair_getj_mid);
                          ^

        libnativeGC05.c:78:19: error: 'pair_geti_mid' may be used uninitialized in this function [-Werror=maybe-uninitialized]
                        i = (*env)->CallIntMethod(env, pair, pair_geti_mid);
                          ^

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  iignatyev Igor Ignatyev
                  Reporter:
                  iignatyev Igor Ignatyev
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: