Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8204834

Fix confusing "allocate" naming in OopStorage

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 12
    • Component/s: hotspot
    • Subcomponent:
      gc
    • Resolved In Build:
      b02
    • CPU:
      generic
    • OS:
      generic

      Description

      The review of JDK-8204097 showed that the "allocate list" nomenclature used internally in OopStorage is confusing. It should have been "allocation list". Make the following name changes throughout the implementation of OopStorage:

      AllocateEntry => AllocationListEntry
      AllocateList => AllocationList
      _allocate_entry => _allocation_list_entry
      _allocate_list => _allocation_list
      allocate_entry() => allocation_list_entry()
      allocate_list() => allocation_list()
        -- these functions are particularly confusing, since they don't
           allocate anything.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kbarrett Kim Barrett
                Reporter:
                kbarrett Kim Barrett
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: