Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8205081

[Graal] Graal unit tests are not suitable for running with jdk11

    XMLWordPrintable

    Details

      Description

      Following graal unit tests are not properly suitable for running with jdk11 and as results fail:

      org.graalvm.compiler.core.test.CheckGraalInvariants
      org.graalvm.compiler.core.test.inlining.PolymorphicInliningTest
      org.graalvm.compiler.core.test.OptionsVerifierTest
      org.graalvm.compiler.core.test.ProfilingInfoTest
      org.graalvm.compiler.debug.test.DebugContextTest
      org.graalvm.compiler.hotspot.test.CompilationWrapperTest
      org.graalvm.compiler.hotspot.test.HsErrLogTest
      org.graalvm.compiler.hotspot.test.OptionsInFileTest
      org.graalvm.compiler.replacements.test.classfile.ClassfileBytecodeProviderTest
      org.graalvm.compiler.replacements.test.classfile.RedefineIntrinsicTest

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              epavlova Ekaterina Pavlova
              Reporter:
              epavlova Ekaterina Pavlova
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: